lnwshop logo
  • ตอบกระทู้
  • ตั้งกระทู้ใหม่
QUOTE 

ปัญหาจายไฟให้ Ethernet Shield

EmbTry
EmbTry
IP: 49.231.30.x
9 เดือนที่ผ่านมา

ต่อไฟด้วยแหล่งจ่ายนอก

อันนี้ต่อไฟภายนอกที่ Jack ไม่ว่า 9V หรือ 5V ไฟ on ของ shield เป็นสีเขียวจางๆครับ 
ลองต่อออกไฟ 5V ก็ไม่มีไฟออก 

แต่พอลองใช้ USB ต่อ

ก็ทำงานได้ปรกติครับ ลองเขียนเป็น Server ก็ปรกติ 

ผมต่ออะไรผิดหรือไม่ครับ มีอะไรเสียบ้างครับ

QUOTE 
ความคิดเห็นที่ #1
เจ้าของร้าน
เจ้าของร้าน
8 เดือนที่ผ่านมา

 

ตรงนี้ผมไม่แน่ใจ ต้องขออภัยจริง ๆ ที่ตอบให้ไใม่ได้ อาจจะกระแสไฟไม่พอ หรือผิดพลาดที่บางจุด ต้องลองเช็คแก้ทีละขึ้นตอนครับ

QUOTE 
ความคิดเห็นที่ #2
ธีรพงษ์
ธีรพงษ์
IP: 49.49.250.x
8 เดือนที่ผ่านมา

ปลดอุปกรณ์อื่นออกหมด เหลือแต่ UNO กับ shield แล้วยังเป็นหรือเปล่า

กด shield ลงสุดแล้วหรือยัง เอาไฟ DC จ่ายเข้า UNO แล้วลองตามขั้นดังนี้

1. วัดแรงดัน Vin, 5V, 3.3V ของ UNO

2. เสีบบ shield ลงไป วัดแรงดัน Vin, 5V, 3.3V ที่ shield ควรได้แรงดันเท่ากัน เพราะมันไม่มีวงจรอะไร มันต่อขาขึ้นมาตรงๆ ถ้าไฟไม่ออก ให้ปลด shield ออก แล้วใช้โอห์มมิเตอร์วัดความต้านทานจากขายาวๆ ข้างล่าง กับ pin ข้างบน ถ้าไม่ได้ 0 โอห์ม ให้สงสัยว่า PCB defect ขาดใน ซึ่งเกิดยากมาก

3. เอา shield ออกจาก UNO แล้วใช้ jumper เสียบ GND, 5V ระหว่าง UNO กับ shield วัดแรงดันขา 3.3V ที่ shield

อาการเหมือนไฟไม่พอ ผมสงสัยว่าคงเสียบ shield ลงไม่สุด ไม่ก็ขา shield สกปรก มีคราบกาว

QUOTE 
ความคิดเห็นที่ #3
EmbTry
EmbTry
IP: 49.231.30.x
8 เดือนที่ผ่านมา
1. วัดแรงดัน Vin, 5V, 3.3V ของ UNO 1.1 ครั้งแรกต่อไฟ 5V ครั้งสอง 9V ที่ขา Jack ผลออกมาเหมือนกันทั้ง 2 คือ วัดที่ขา Vin 5V 3.3V ของ UNO ทั้งหมดเป็นประมาณ 0.5 หมดเลย 1.2 เลยลองต่อด้วยไฟเข้าจาก USB วัดที่ขา Vin ได้ 4.9V, 5V ได้ 4.9V, 3.3 ได้ 3.2V ทดลองแค่ข้อแรก แปลว่า Shield ไม่น่าเป็นอะไร แต่ว่าบอร์ด UNO ของผมเสีย ใช่ไหมครับเนี่ย
QUOTE 
ความคิดเห็นที่ #4
เจ้าของร้าน
เจ้าของร้าน
8 เดือนที่ผ่านมา

อาจจะเสียภาคจ่ายไฟที่แจ๊ก DC ตอบระบุเฉพาะจุดไม่ได้ ตรงนี้ต้องลองทดสอบดูนะครับ

QUOTE 
ความคิดเห็นที่ #5
ธีรพงษ์
ธีรพงษ์
IP: 129.192.198.x
8 เดือนที่ผ่านมา

แล้วที่หัว adapter ตัวผู้นั้น มีไฟออกมาหรือเปล่าครับ

หรือปรับขั้วบวกลบสลับกันหรือเปล่า รูข้างในของ DC adapter ต้องเป็นขั้วบวกนะ

แรงดันที่ DC adapter ต้อง 7-12V ถ้าจ่าย 5.5-6V มันก็อาจจะไม่ออก

ลองป้อนเข้า Vin โดยตรง ตัว Vin รับไฟ 6-12V

ถ้าทุกอย่างปกติ ก็คาดว่าเสียที่ภาคจ่ายไฟจาก DC jack ของ UNO ครับ

QUOTE 
ความคิดเห็นที่ #6
เจ้าของร้าน
เจ้าของร้าน
8 เดือนที่ผ่านมา

วงจร arduino uno จะมีวงจรตรวจสอบภาคจ่ายไฟว่าจ่ายาาจาก usb หรือ jack โดยถ้ามีไฟจาก jack จะเลือกเป็นอันดับแรก อ้างอิงตามวงจร schematic ดังนี้

https://www.arduino.cc/en/uploads/Main/arduino-uno-schematic.pdf

ในกรณีนี้บอกว่าไฟจาก jack ไม่ติด แต่ไฟจาก usb ติด อาจจะเป็นไปได้ว่าวงจรเลือกแหล่งจ่ายไฟมีปัญหา สำหรับภาคเรกูเลต ไม่น่ามีปัญหาเพราะวัดได้ 3.3V และ 5V ปกติ

ชิฟ IC atmega328P ที่เป็นตัวเก็บโปรแกรม MCU Arduino ก็ไม่มีปัญหา อัพโหลดโคดทำงานได้ปกติ

จึงอาจจะเสียภาคจ่ายไฟที่แจ๊ก DC ตอบ ระบุเฉพาะจุดไม่ได้ ตรงนี้ต้องลองทดสอบดูนะครับ

1
แสดงความคิดเห็นที่ 1-6 จากทั้งหมด 6 ความคิดเห็น
ข้อความ
ชื่อผู้โพส
ข้อมูลสำหรับการติดต่อกลับ (ไม่เปิดเผย เห็นเฉพาะเจ้าของร้าน)
อีเมล
เบอร์มือถือ
  • ตอบกระทู้

หมวดหมู่สินค้า

สมาชิก Arduino All

เข้าสู่ระบบด้วย
เข้าสู่ระบบ
สมัครสมาชิก

ยังไม่มีบัญชีเทพ สร้างบัญชีใหม่ ไม่เกิน 5 นาที
สมัครสมาชิก (ฟรี)

Arduino All ขายดี

รหัสสินค้า A015
270.00 บาท
  • สั่งซื้อ
รหัสสินค้า A233
5.00 บาท
  • สั่งซื้อ
รหัสสินค้า A115
10.00 บาท
  • สั่งซื้อ
รหัสสินค้า A097
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A238
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A474
7.00 บาท
  • สั่งซื้อ
รหัสสินค้า A014
95.00 บาท
  • สั่งซื้อ
รหัสสินค้า A237
4.00 บาท
  • สั่งซื้อ
Go to Top