lnwshop logo
  • ตอบกระทู้
  • ตั้งกระทู้ใหม่
QUOTE 

สอบถามการต่อ ESP-01S เข้า UNO R3 ครับ

nuugut
nuugut (Guest)
IP: 182.52.249.x
5 เดือนที่ผ่านมา

ผมซื้อ WiFi Module ESP-01S มา จะต่อกับ Arduino UNO R3 โดยตรงเลย ไม่ผ่าน Breadboard

ต้องต่อขาไหนเข้าขาไหนบ้างครับ เท่าที่ผมเข้าใจ

ต่อ (จาก ESP-01S เข้าบอร์ด)

TX -> RX

RX -> TX

GND -> GND

3V3 -> 3.3V

แบบนี้ถูกไหมครับ ผมต่อแล้วไม่มีไฟขึ้นที่ ESP-01S ครับ (โดยปกติ ถ้าต่อถูกต้อง จะมีไฟติดที่ ESP-01S ไหมครับ)

ขอบคุณครับ

QUOTE 
ความคิดเห็นที่ #1
เจ้าของร้าน
เจ้าของร้าน
5 เดือนที่ผ่านมา

เช็คการใช้งาน esp8266 กับ arduino ตามนี้ ไฟจะไม่ติดเอง สามารถสั่งงานได้ครับ

https://www.arduinoall.com/b/23

 

QUOTE 
ความคิดเห็นที่ #2
nuugut
nuugut (Guest)
IP: 182.52.249.x
5 เดือนที่ผ่านมา
รบกวนขอถามหน่อยครับว่า Vcc-3.3V กับ CH_PD-3.3V อันนี้ต้องยังไงครับ เพราะ 3.3V ในบอร์ด Arduino มีช่องเดียว ขอบคุณครับ (ผมมือใหม่)
QUOTE 
ความคิดเห็นที่ #3
เจ้าของร้าน
เจ้าของร้าน
5 เดือนที่ผ่านมา

ต่อกับบอร์ดทดลอง ตรงริมสุดครับ จะมีที่เป็นเส้นยาว ๆ ขยายช่องต่อ 3.3V ได้

QUOTE 
ความคิดเห็นที่ #4
nuugut
nuugut (Guest)
IP: 101.51.88.x
5 เดือนที่ผ่านมา
ต่อกับบอร์ดทดลอง งั้นก็หมายความว่าต้องใช้ Breadboard ใช่ไหมครับ ถึงจะต่อได้ ถ้าไม่มี Breadboard ก็ต่อไม่ได้
QUOTE 
ความคิดเห็นที่ #5
เจ้าของร้าน
เจ้าของร้าน
5 เดือนที่ผ่านมา

ต่อยังไงก็ได้ครับ ถ้าไม่มี breadboard ก็ตัดสายไฟมาพันกันเพื่อให้เป็น 2 เส้น

QUOTE 
ความคิดเห็นที่ #6
nuugut
nuugut (Guest)
IP: 101.51.88.x
5 เดือนที่ผ่านมา
พอจะมีวิธีการตัดสายไฟมาพันกันให้เป็นสองเส้นไหมครับ
QUOTE 
ความคิดเห็นที่ #7
เจ้าของร้าน
เจ้าของร้าน
5 เดือนที่ผ่านมา

ใช้คัทเตอร์ตัดสายไฟออก แล้วเอาปลายมาทบกัน จากนั้นหมุน ๆ ครับ

http://www.tic.co.th/index.php?op=tips-detail&id=68

QUOTE 
ความคิดเห็นที่ #8
nuugut
nuugut (Guest)
IP: 101.51.88.x
5 เดือนที่ผ่านมา
ดูจากคลิปสอนวิธีการใช้งานคือ ถ้าต่อสายไฟถูกต้องที่ตัว module ESP8266 จะมีไฟสีแดงบอกว่าตอนนี้มี power ใช่ไหมครับ
QUOTE 
ความคิดเห็นที่ #9
เจ้าของร้าน
เจ้าของร้าน
5 เดือนที่ผ่านมา

ตามคลิปเลยครับ LED สามารถสั่งงานได้ด้วยโปรแกรม หรือ firmware

สามารถทดลองโดยใช้โคดง่าย ๆ เช่นไฟกระพริบทดลองได้

QUOTE 
ความคิดเห็นที่ #10
nuugut
nuugut (Guest)
IP: 101.51.76.x
5 เดือนที่ผ่านมา
ตอนนี้ผมต่อตามของที่พี่สอนแล้วครับ ผ่านบอร์ดทดลอง แต่ผมไม่สามารถอัพโหลดโค้ดลง Arduino ได้ เป็นแบบนี้ครับ 28bc8040e39ef636ba93eab186007a38.png https://www.img.in.th/image/fOU8 แต่พอผมถอดสาย ESP-01S ออก อัพโหลดได้ปกติ รบกวนขอคำแนะนำด้วยครับ
1
2
ถัดไป ›
แสดงความคิดเห็นที่ 1-10 จากทั้งหมด 16 ความคิดเห็น
ข้อความ
ชื่อผู้โพส
ข้อมูลสำหรับการติดต่อกลับ (ไม่เปิดเผย เห็นเฉพาะเจ้าของร้าน)
อีเมล
เบอร์มือถือ
  • ตอบกระทู้

หมวดหมู่สินค้า

สมาชิก Arduino All

เข้าสู่ระบบด้วย
เข้าสู่ระบบ
สมัครสมาชิก

ยังไม่มีบัญชีเทพ สร้างบัญชีใหม่ ไม่เกิน 5 นาที
สมัครสมาชิก (ฟรี)

Arduino All ขายดี

รหัสสินค้า A015
270.00 บาท
  • สั่งซื้อ
รหัสสินค้า A233
5.00 บาท
  • สั่งซื้อ
รหัสสินค้า A115
10.00 บาท
  • สั่งซื้อ
รหัสสินค้า A238
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A097
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A014
90.00 บาท
  • สั่งซื้อ
รหัสสินค้า A474
5.00 บาท
  • สั่งซื้อ
รหัสสินค้า A237
4.00 บาท
  • สั่งซื้อ
Go to Top