lnwshop logo
  • ตอบกระทู้
  • ตั้งกระทู้ใหม่
QUOTE 

Arduino MEGA 2560 R3 ใช้ชิฟ USB CH340

wichitchai
wichitchai
IP: 124.122.44.x
2 ปีที่ผ่านมา

คือผมสั่ง Arduino MEGA 2560 R3 ใช้ชิฟ USB CH340 มาใช้แทน Mega2560 R3 ตัวเก่าอะครับแล้วพออัพข้อมูลแล้วมันใช้เวลาแสดงผล 3 วินาทีต่อ1ค่า ซึ่งเทียบกับตัวเก่าแล้วมันได้ 11 ค่าใน 1 วินาทีอ่ะครับ

สเปคมันเท่ากันจริงหรอครับ หรือผิดพลาดยังไงครับ

 

****ผมลองเสียบวัดค่าดูแล้วทั้ง2ตัว****

QUOTE 
ความคิดเห็นที่ #1
เจ้าของร้าน
เจ้าของร้าน
2 ปีที่ผ่านมา

อ้างอิงตาม วงจร arduino mega2560 ตามนี้ครับ

http://www.arduino.cc/en/Main/ArduinoBoardMega2560

วงจร schematic : Mega 2560 Schematic - Arduino

ขอไล่ดูทีละส่วนนะครับ

1. วงจรหลักใช้ชิฟ Atmega2560 ซึ่งการทำงานจริง จะใช้ความสามารถของชิฟนี้ ทั้ง 2 รุ่น เป็นตัวเดียวกันจึงประสิทธิภาพเท่ากัน ลองศึกษาการทำงาน arduino standalone ในบทความประกอบครับ

2. วงจรภาคจ่ายไฟ เหมือนกันทุกอย่าง เป็นเรกูเลต 3.3V กับ 5V วงจรเดียวกัน

3. ภาคติดต่อ usb ต่างกันตรงนี้

  • - รุ่นปกติใช้ ชิฟ atmega8u2-mu
  • - รุ่นใหม่ใช้ชิฟ CH340

ภาค usb นี้ใช้สำหรับติดต่อกับเครื่องคอมผ่านทาง serial หรือที่เห็นใน serial monitor ครับ เวลาโปรแกรมลงบอร์ดก็ใช้ส่วนนี้

จากข้อมูลที่ให้มา สามารถอัพโหลดโคดลงบอร์ด (ภาค usb ttl) และทำงานได้ปกติ(ภาค mcu atmega2560) แสดงว่าบอร์ดทำงานได้ไม่มีปัญหา

arduino mega2560 2 บอร์ดนี้ จะต่างกันที่ภาค usb ซึ่งที่บอกว่าให้ข้อมูลออกมาไม่เท่ากัน อาจจะเป็นกับชิฟ CH340 ซึ่งอาจมีความเร็วไม่เท่า atmega8u2-mu อันนี้ผมก็ไม่แน่ใจ เพิ่งเคยเห็นปัญหานี้

 

ทีนี้ขอตอบที่ถามมา ถูกผิดยังไงขออภัยไว้ด้วยนะครับ

คือผมสั่ง Arduino MEGA 2560 R3 ใช้ชิฟ USB CH340 มาใช้แทน Mega2560 R3 ตัวเก่าอะครับแล้วพออัพข้อมูลแล้วมันใช้เวลาแสดงผล 3 วินาทีต่อ1ค่า ซึ่งเทียบกับตัวเก่าแล้วมันได้ 11 ค่าใน 1 วินาทีอ่ะครับ

- อาจจะเป็นกับการส่งข้อมูลทาง serial port ที่ความเร็วไม่เท่ากัน อันนี้เดาไม่รู้จริง ๆ ครับยังไม่เคยเจอปัญหาแบบนี้ แต่ถ้าไม่ได้แสดงผลออก serial monitor ใช้ความสามารถของชิฟ atmega2560 จะต้องได้เท่ากันครับ เพราะชิฟตัวเดียวกัน

สเปคมันเท่ากันจริงหรอครับ หรือผิดพลาดยังไงครับ

- สเปคไม่เท่ากันครับ ต่างกันที่ภาค usb แต่ความสามารถของชิฟ MCU Atmega2560 ทำงานเท่ากัน 100% เพราะเป็นตัวเดียวกัน บอร์ดสามารถทำงานปกติ อัพโหลดโคดลงได้ ตรงนี้เห็นได้ว่าไม่ผิดพลาดครับ

 

 

 

 

1
แสดงความคิดเห็นที่ 1-1 จากทั้งหมด 1 ความคิดเห็น
ข้อความ
ชื่อผู้โพส
ข้อมูลสำหรับการติดต่อกลับ (ไม่เปิดเผย เห็นเฉพาะเจ้าของร้าน)
อีเมล
เบอร์มือถือ
  • ตอบกระทู้

หมวดหมู่สินค้า

สมาชิก Arduino All

เข้าสู่ระบบด้วย
เข้าสู่ระบบ
สมัครสมาชิก

ยังไม่มีบัญชีเทพ สร้างบัญชีใหม่ ไม่เกิน 5 นาที
สมัครสมาชิก (ฟรี)

Arduino All ขายดี

รหัสสินค้า A015
270.00 บาท
  • สั่งซื้อ
รหัสสินค้า A233
5.00 บาท
  • สั่งซื้อ
รหัสสินค้า A115
10.00 บาท
  • สั่งซื้อ
รหัสสินค้า A097
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A238
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A474
7.00 บาท
สินค้าหมด
รหัสสินค้า A014
100.00 บาท
  • สั่งซื้อ
รหัสสินค้า A237
4.00 บาท
  • สั่งซื้อ
Go to Top