lnwshop logo
  • ตอบกระทู้
  • ตั้งกระทู้ใหม่
QUOTE 

บอร์ด Arduino UNO R3 ไม่ทำงาน

(Guest)
ผู้ฝึกหัด (Guest)
IP: 171.100.21.x
11 เดือนที่ผ่านมา

ผมสั่งซื้อบอร์ด Arduino UNO R3 และ ESP8266 แล้วลองเขียน Arduino ติดต่อกับ ESP8266 ทำงานได้ปกติ

แต่ต้องเปิด Serial Monitor ทุกครั้ง หากไม่เปิด Serial Monitor จะไม่ทำงาน ไม่เกาะ Network และ Ping หาไม่เจอ ควรแก้ไขยังไงครับ

 

ขอบคุณครับ

QUOTE 
ความคิดเห็นที่ #1
เจ้าของร้าน
เจ้าของร้าน
11 เดือนที่ผ่านมา

อันนี้ต้องลอง Debug ดู ไม่น่าจะเกี่ยวกับอุปกรณ์เพราะทำงานได้ปกติทั้ง 2 ตัว ตรง software ที่เขียน ปกติไม่เกี่ยวกับว่าเปิด serial แล้วถึงจะทำงาน อันนี้ไม่แน่ใจ ต้องลองเช็คอีกทีครับ 

QUOTE 
ความคิดเห็นที่ #2
(Guest)
ผู้ฝึกหัด (Guest)
IP: 203.11.74.x
11 เดือนที่ผ่านมา

ขอบคุณครับ

ขอถามเพิ่มเติมครับ ปุ่ม Reset บนบอร์ด Arduino เมื่อกดแล้วเปรียบเสมือนว่าตัว Board จะไปทำงานที่ setup() ใช่ไหมครับ คือเริ่มการทำงานใหม่

QUOTE 
ความคิดเห็นที่ #3
เจ้าของร้าน
เจ้าของร้าน
11 เดือนที่ผ่านมา

ใช่ครับ Reset จะกลับไปทำงานที่ offset 0 เริ่มต้นที่ตำแหน่ง setup() ด้วยครับ

QUOTE 
ความคิดเห็นที่ #4
(Guest)
ผู้ฝึกหัด (Guest)
IP: 203.11.74.x
11 เดือนที่ผ่านมา

ขอบคุณมากครับผม รักร้านนี้จัง ของส่งไว บริการดี Laughing

QUOTE 
ความคิดเห็นที่ #5
เจ้าของร้าน
เจ้าของร้าน
11 เดือนที่ผ่านมา

ยินดีครับ : )

QUOTE 
ความคิดเห็นที่ #6
(Guest)
ภูริทัต (Guest)
IP: 110.171.148.x
11 เดือนที่ผ่านมา

แต่ต้องเปิด Serial Monitor ทุกครั้ง หากไม่เปิด Serial Monitor จะไม่ทำงาน ไม่เกาะ Network และ Ping หาไม่เจอ ควรแก้ไขยังไงครับ

ช่วยเดานะครับ
  เวลาเปิด  Serial Monitor มันจะไป reset ตัวบอร์ด arduino ลองไม่เปิด  Serial Monitor  ดูนะครับ แต่ลองกดปุ่ม reset บนบอร์ด arduino ดู ว่า esp8266 ทำงานได้เกาะ network ติดหรือเปล่า
ถ้ากดปุ่ม reset แล้วทำได้ปรกติแสดงว่า เป็นที่ code ลองดูครับ

QUOTE 
ความคิดเห็นที่ #7
(Guest)
ผู้ฝึกหัด (Guest)
IP: 203.11.74.x
11 เดือนที่ผ่านมา

ขอบคุณครับคุณภูริทัต

ผมได้ลองกดปุ่ม Reset แล้ว ปรากฏว่าทำงานได้เป็นบางครั้ง Ping เจอแปปเดียว ประมาณ 5 ครั้ง แล้วก็หลุดไปเลยและลองกดปุ่ม Reset อีกครั้ง ก็ Ping ไม่เจอแล้ว

ลืมบอกไปตอนที่เทสผมก็ยังเสียบสายแลนอยู่เหมือนเดิม อาจจะเป็นที่เวลาผมต่อสายระหว่าง UNO กับ ESP ผมไม่ได้ถอดสาย USB ออก เลยทำให้บอร์ดมีปัญหาหรือเปล่าครับ Yell

QUOTE 
ความคิดเห็นที่ #8
เจ้าของร้าน
เจ้าของร้าน
11 เดือนที่ผ่านมา

ขอบคุณ คุณภูริทัต ที่ช่วยแชร์ความรู้

จากที่เคยทดลอง เสียบสาย usb ระหว่าง uno กัย esp ก็ทำงานปกติ หรือจะลองถอดออก ก็ทำงานได้ปกติเหมือนกัน เคยทดสอบเปิดไว้ 7 วันแบบเดี่ยว ๆ ไม่มีปัญหาครับ หรืออาจจะเป็น logic level เพื่อแปลง logic 5V เป็น 3.3V ที่ต้องใส่เพิ่มอันนี้ก็ไม่แน่ใจของผมก็ไม่ได้ต่อ

QUOTE 
ความคิดเห็นที่ #9
(Guest)
ผู้ฝึกหัด (Guest)
IP: 203.11.74.x
11 เดือนที่ผ่านมา

พิมพ์ผิดครับ ขณะที่ผมต่อสาย ผมยังเสียบสาย USB อยู่เสมอ (ไม่แน่ใจว่าเกี่ยวกันไหม เพราะมีไฟเข้าบอร์ด UNO ตลอด แต่ผมเสียบและถอดสายจาก ESP ตลอดเลย)

QUOTE 
ความคิดเห็นที่ #10
(Guest)
ภูริทัต (Guest)
IP: 110.171.148.x
10 เดือนที่ผ่านมา

ถ้าจะเล่น esp8266 กับ uno r3 ให้สนุก แนะนำให้ออกแบบลายปริ้นทำเป็นแบบชิล ไว้เสียบบน uno ดีกว่าการจั๊มสายครับ เสถียรกว่า แน่นอนกว่า  ไม่แน่ใจว่ามีขายรึยัง ตอนผมหัดเล่น ผมดึงเข้าดึงออกบ่อยเจอปัญหาแปลกๆก็เพราะสายจั้มหลวมนี่แหละ เลยทำชิลเองเลย ลองดูครับ  Smile

1
2
ถัดไป ›
แสดงความคิดเห็นที่ 1-10 จากทั้งหมด 15 ความคิดเห็น
ชื่อ
อีเมล
ข้อความ
  • ตอบกระทู้

หมวดหมู่สินค้า

สมาชิก Arduino All

เข้าสู่ระบบด้วย
เข้าสู่ระบบ
สมัครสมาชิก

ยังไม่มีบัญชีเทพ สร้างบัญชีใหม่ ไม่เกิน 5 นาที
สมัครสมาชิก (ฟรี)

Arduino All ขายดี

รหัสสินค้า A015
300.00 บาท
  • สั่งซื้อ
รหัสสินค้า A233
5.00 บาท
  • สั่งซื้อ
รหัสสินค้า A115
10.00 บาท
  • สั่งซื้อ
รหัสสินค้า A238
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A237
4.00 บาท
  • สั่งซื้อ
รหัสสินค้า A014
90.00 บาท
  • สั่งซื้อ
รหัสสินค้า A225
5.00 บาท
  • สั่งซื้อ
รหัสสินค้า A474
7.00 บาท
  • สั่งซื้อ
รหัสสินค้า A097
4.00 บาท
  • สั่งซื้อ
Go to Top